简介：Motorola SM56 软件调制解调器软件用户指南

返回到“目录”页

简介：Motorola SM56 软件调制解调器用户指南

主要功能

感谢您使用 SM56 调制解调器。该调制解调器支持 V.90/V.92 和 K56flex™ 连接，为您的个人计算机和远程之间提供高速通信。您可以：

• 在 V.90/V. 92 或 K56flex™ 模式下以高达 56.0 Kbps 的速率接收数据，实现快速 Internet 访问

• 使用计算机发送和接收传真，速度高达 14.4 Kbps

• 将计算机用作视频电话，拨打和接听视频电话的呼叫。

• 象使用一部电话应答设备（对数据/传真Data/Fax调制解调器不适用）一样使用您的计算机。

• 象使用一部免提式电话一样使用您的计算机，拨出和接受语音呼叫（仅适用于数据/传真/免提式电话调制解调器。）

• 参照您计算机的语音应用程序用户手册来使用应答设备和免提式电话功能。

我的调制解调器型号是什么？

注意：SM56 能够进行 56Kbps 连接，但由于各种电话线路的影响，实际使用时速度可能会降低。

主要功能

本调制解调器：

• 支持 V.90/V.92 56K 标准和 K56flex，以达到最大的 ISP 互操作性

• 支持 V.44 数据压缩，以实现从支持该技术的 ISP 处获得最高的 Internet 下载速度

• 支持到符合 H.234 的视频电话应用程序的 V.80 接口

• 支持 V.34、V.32bis、V.32、V.23、V.22bis、V.22、V.21、Bell 212A 和 Bell 103 调制标准

• 支持一级传真纠错模式

• 支持 V.17、V.21、V.29、V.27ter Group III 传真模式

• 支持 V.42、LAP-M 和 MNP 2-4 纠错协议

• 支持 V.42bis 和 MNP 5 数据压缩协议

• 支持从 300 bps 到 115.2 Kbps 的 DTE 速率

制造商在设计该调制解调器时考虑了轻松升级的问题。您只需从 Internet 下载即可升级调制解调器软件，从而可跟上在功能和支持的通信速率上的飞速变化。在许多情况下，此类升级不需要新硬件。有关详细信息，请与您的调制解调器供应商联系。

返回到“目录”页


ABT：Motorola SM56 软件调制解调器用户指南

应答音。


如何添加 AT 命令：Motorola SM56 软件调制解调器用户指南

1. 打开控制面板。

2. 双击调制解调器图标。

3. 选择 Motorola SM56 调制解调器。

4. 单击属性。

5. 选择连接。

6. 单击高级选项卡。

7. 在附加设置框中，添加所需的命令。尽管“附加设置”框将接受对 AT 前缀的添加，但 AT 前缀并不是必需的。


应用程序的兼容性：Motorola SM56 软件调制解调器用户指南

该调制解调器支持运行于以下环境的通信应用程序：

• Windows 98 或 Windows Millenium 或 Windows XP

• Windows 2000 和 Window NT 4.0

• Windows 98 DOS 框中


+++（加-加-加）指令：Motorola SM56 软件调制解调器用户指南

该指令为换码序列，使调制解调器停止传输数据（如果它正在传输）并进入指令模式。

如果用计算机键盘发出此指令，需在您的通信应用程序终端窗口中，键入 ＋ 号三次。

注意：不要在 +++ 指令后按回车。否则，将取消这个指令。


AT 和 AT&（“和”符号）命令：Motorola SM56 软件调制解调器用户指南

返回到“目录”页

AT 和 AT&（“和”符号）：Motorola SM56 软件调制解调器用户指南

调制解调器响应以下 AT 和 AT& 命令选项。

字母 AT（或 at）必须先于所有命令，A/ 和 +++ 除外。出厂时默认的选项带有下划线。

命令 | 选项 | 说明
A | （无） | 应答呼入
A/ | （无） | 重复上一条命令 重新将上一条命令发布到调制解调器。 （不要按回车键；按下 / 键之后，将立即执行该命令。）
D | （无） | 拨号 指示调制解调器拨打您紧接在 ATD 命令后输入的电话号码。例如：ATD5554678。 注意：如果在免提式电话模式下使用多 ATD 命令，调制解调器须在拨号音检测后被强制盲拨号。
E |  | 将异步（键盘）输入回应到终端 决定是将您用键盘键入的字符是在终端仿真窗口（若处于活动状态）显示（回应）还是在通信应用程序显示（回应）。
 | E0 | 禁用
 | E1 | 启用
H |  | 挂机
 | H0 | 挂机（断开电话线；挂断）
 | H1 | 摘机（连接电话线）
I |  | 向调制解调器请求信息
 | I0 | "5600"
 | I1 | "255"
 | I2 | 确定
 | I3 | 软件版本
 | I4 | 确定
 | I5 | 断开原因
 | I6 | 国家/地区代码
 | I7 | 产品代码
L |  | 扬声器音量 该参数确定例如拨号、振铃、占线、协商等声音的音量，这些音量仅用来对呼叫进展状况进行监控。
 | L0, L1 | 低
 | L2 | 中
 | L3 | 高
M |  | 扬声器控制
 | M0 | 关闭
 | M1 | 仅排序期间开启
 | M2 | 始终开启
 | M3 | 拨号期间关闭；呼叫进行期间开启；数据传输期间关闭
O |  | 返回到在线模式 该参数决定调制解调器是在从换码模式转换到数据模式后，还是在拨号串中加入分号后启动重新排序。
 | O0 | 不重新排序
 | O1 | 重新排序
 | O2 | 启动速率再协商
 | O3 | 静止速率再协商
P | P | 脉冲拨号
Q |  | 结果代码显示 调制解调器可以向计算机发出一些结果代码和连接消息，作为正在连接或连接失败、建立数据速率以及建立纠错和数据压缩协议等的结果。参见：ATV；AT\V；ATX。
 | Q0 | 启用显示
 | Q1 | 禁用显示
T | T | 音频拨号 该命令指示调制解调器使用 DTMF 音频拨号。
V |  | 结果代码格式 决定调制解调器是向通信应用程序发送短格式消息还是长格式消息，指明连接状态、速率和模式。
 | V0 | 返回数字代码（短格式）
 | V1 | 返回文本（长格式）
X |  | 选择要返回的呼叫进展结果代码
 | X0 | 无载波；连接。调制解调器报告没有载波信号；连接成功/失败；调制解调器未等候拨号音就拨号
 | X1 | 无载波；连接；连接 <速率>。 调制解调器报告没有载波信号；连接成功/失败；计算机数据速率已建立
 | X2 | 无载波；连接；连接 <速率>； 无拨号音。调制解调器报告没有载波信号；连接成功/失败；计算机数据速率已建立；没有拨号音
 | X3 | 无载波；连接；连接 <速率>；占线音。调制解调器报告没有载波信号；连接成功/失败；计算机数据速率已建立；出现占线信号
 | X4 | 无载波；连接；连接 <速率>；无拨号音；占线音。调制解调器报告没有载波信号；连接成功/失败；计算机数据速率已建立；没有拨号音；出现占线信号
Z | Z | 将调制解调器参数复位到默认配置
&C |  | DCD 控制
 | &C0 | 始终声明
 | &C1 | 只在数据模式时声明
&D |  | DTR 控制 决定调制解调器如何从 DTE 响应 DTR 信号。
 | &D0 | 忽略 DTR
 | &D1 | 当 DTR 从声明转换为取消声明时，进入命令模式
 | &D2 | 当 DTR 从声明转变为取消声明时断开呼叫
 | &D3 | 当 DTR 从声明转变为取消声明时，将调制解调器参数复位到默认配置
&F |  | 将调制解调器初始化为默认的出厂时配置。
&G |  | 保护音
 | &G0 | 关闭
 | &G1 | 550 Hz 保护音
 | &G2 | 1800 Hz 保护音
&I |  | 拨号 TX 级
 | &In | n 级；其中 n 为 0 到 15 之间的数值。默认值为 9
 | &I99 | 自动级
&P |  | 脉冲周期 当调制解调器被指定为采用脉冲拨号时使用。
 | &P0 | 40/60 连接/断开比
 | &P1 | 33/67 连接/断开比
 | &P2 | 38/62 连接/断开比
&R |  | CTS 控制
 | &R0 | 一般
 | &R1 | 始终开启
&S |  | DSR 控制
 | &S0 | 始终开启
 | &S1 | 当调制解调器识别远程连接时开启
&T |  | 测试
 | &T0 | 终止测试
 | &T1 | 启动本地模拟环回测试 以前连接电话线到调制解调器使用这个命令。 先设置 S 寄存器 46 = 23 (ATS46=23)，再执行 &T1。
&V |  | 调制解调器状态
 | &V0 | 短格式报告
 | &V1 | 当前或上次连接报告
 | &V2 | 长格式报告

表 1：AT 和 AT& 命令


AT*（星号）命令：Motorola SM56 软件调制解调器用户指南

调制解调器响应以下 AT* 命令选项。

字母 AT（或 at）必须先于所有命令，A/ 和 +++ 除外。出厂时默认的选项带有下划线。

命令 | 选项 | 说明
*DD |  | 拨号等候 指定调制解调器在处理拨号串期间遇到 W 或 w 时等待的时间间隔
 | *DD0 | 2 秒
 | *DD1 | 3 秒
 | *DD2 | 4 秒
 | *DD3 | 5 秒
 | *DD4 | 12 秒
 | *DD5 | 15 秒
 | *DD6 | 20 秒
 | *DD7 | 30 秒
 | *DD8 | 40 秒
*LS |  | 低速操作协议 通过该协议，可以选择与速率非常低或较老式的调制解调器通信时采用的通信协议。
 | *LS0 | Bell 103
 | *LS1 | ITU-T V.21（国际标准）
 | *LS2 | Bell 103 或 ITU-T V.21（自动确定）
*MM |  | 调制模式
 | *MM0 | V.34 自动调制
 | *MM1 | V.21
 | *MM2 | Bell 103
 | *MM4 | V.22/Bell 212
 | *MM5 | V.22bis
 | *MM6 | V.23
 | *MM10 | 仅 V.32
 | *MM11 | V.32 bis
 | *MM12 | 仅 V.34
 | *MM13 | 仅 K56flex(TM)
 | *MM14 | K56flex(TM) 自动调制
 | *MM15 | 仅 V.90
 | *MM16 | V.90 自动
 | *MM17 | 仅 V.92
 | *MM18 | V.92 自动

表 1：AT*（星号）命令


AT 命令 - 基本原理：Motorola SM56 软件调制解调器用户指南

注意 (AT) 命令用于用户控制和监控调制解调器。通常，通信应用程序自动发布这些命令，因此用户无需知道这些命令及其选项。

然而，要为某个应用程序自定义配置调制解调器，或要优化调制解调器的性能，用户可以自己通过通信应用程序发布命令。在大多数通信应用程序中，都提供菜单项或选项，用来输入扩展或自定义的 AT 命令。请参见通信应用程序文档。

用户也可以通过直接从简单的终端仿真应用程序发布 AT 命令来配置调制解调器。HyperTerminal 就是此类应用程序之一，它出现在运行 Windows 的计算机上。

要从终端仿真应用程序发布 AT 命令，必须确保调制解调器处于命令模式（在此模式下它能检测和响应命令），而不是处于数据模式（在此模式下它传送和接收数据）。要从数据模式转换为命令模式，请输入 +++。无需按回车键。

输入 AT 命令时，应用以下基本规则：

• 输入的 AT 命令可以是大写字母、小写字母或大小写混合文本。

• 字符 AT 是所有 AT 命令的开头，A/ 和 +++ 命令除外

• 用作回车键的键在 S 寄存器 S3 中指定

• 命令最长为 64 个字符。

在一行中可以输入多个 AT 命令，而且可以仅在开头使用一个 AT 字符来将这些命令链接起来。但是，某些命令必须出现在命令行的开头或结尾。


AT%（百分比）和 AT\（反斜杠）命令：Motorola SM56 软件调制解调器用户指南

调制解调器响应以下 AT% 和 AT\ 命令选项。

字母 AT（或 at）必须先于所有命令，A/ 和 +++ 除外。出厂时默认的选项带有下划线。

命令 | 选项 | 说明
%B |  | 最大调制率 设置调制解调器以数据调制模式连接时使用的最大速率，用于执行 Internet 访问和文件传输等功能
 | %B0 | 调制解调器支持的最大调制解调器速率
 | %B1 | 300 bps
 | %B2 | 1.2 Kbps
 | %B3 | 2.4 Kbps
 | %B4 | 4.8 Kbps
 | %B6 | 9.6 Kbps
 | %B7 | 7.2 Kbps
 | %B8 | 12.0 Kbps
 | %B9 | 14.4 Kbps
 | %B11 | 16.8 Kbps
 | %B12 | 19.2 Kbps
 | %B13 | 21.6 Kbps
 | %B14 | 24.0 Kbps
 | %B15 | 26.4 Kbps
 | %B16 | 28.8 Kbps
 | %B17 | 31.2 Kbps
 | %B18 | 33.6 Kbps
 | %B19 | 32.0 Kbps
 | %B20 | 34.0 Kbps
 | %B21 | 36.0 Kbps
 | %B22 | 38.0 Kbps
 | %B23 | 40.0 Kbps
 | %B24 | 42.0 Kbps
 | %B25 | 44.0 Kbps
 | %B26 | 46.0 Kbps
 | %B27 | 48.0 Kbps
 | %B28 | 50.0 Kbps
 | %B29 | 52.0 Kbps
 | %B30 | 54.0 Kbps
 | %B31 | 56.0 Kbps
 | %B32 | 58.0 Kbps
 | %B33 | 60.0 Kbps
 | %B34 | 28000 bps
 | %B35 | 29333 bps
 | %B36 | 30666 bps
 | %B37 | 33333 bps
 | %B38 | 34666 bps
 | %B39 | 37333 bps
 | %B40 | 38666 bps
 | %B41 | 41333 bps
 | %B42 | 42666 bps
 | %B43 | 45333 bps
 | %B44 | 46666 bps
 | %B45 | 49333 bps
 | %B46 | 50666 bps
 | %B47 | 53333 bps
 | %B48 | 54666 bps
%C |  | 数据压缩 (DC) 模式 决定调制解调器是否执行数据压缩方法，即通过减少用来代表数据的比特数来增加有效的数据速率
 | %C0 | 禁用压缩
 | %C1 | 启用压缩
%D |  | 断开缓冲延迟 控制调制解调器检测到断开请求后，与电话线断开之前的延迟
 | %D0 | 禁用延迟
 | %Dn | 延迟 n 秒（其中 n = 1 到 255）
%L |  | 最小调制速率 设置调制解调器以数据调制模式连接时使用的最小速率。
 | %L0 | 调制解调器支持的最小调制解调器速率 (300 bps)
 | %L1 | 300 bps
 | %L2 | 1.2 Kbps
 | %L3 | 2.4 Kbps
 | %L4 | 4.8 Kbps
 | %L7 | 7.2 Kbps
 | %L6 | 9.6 Kbps
 | %L8 | 12.0 Kbps
 | %L9 | 14.4 Kbps
 | %L11 | 16.8 Kbps
 | %L12 | 19.2 Kbps
 | %L13 | 21.6 Kbps
 | %L14 | 24.0 Kbps
 | %L15 | 26.4 Kbps
 | %L16 | 28.8 Kbps
 | %L17 | 31.2 Kbps
 | %L18 | 33.6 Kbps
 | %L19 | 32.0 Kbps
 | %L20 | 34.0 Kbps
 | %L21 | 36.0 Kbps
 | %L22 | 38.0 Kbps
 | %L23 | 40.0 Kbps
 | %L24 | 42.0 Kbps
 | %L25 | 44.0 Kbps
 | %L26 | 46.0 Kbps
 | %L27 | 48.0 Kbps
 | %L28 | 50.0 Kbps
 | %L29 | 52.0 Kbps
 | %L30 | 54.0 Kbps
 | %L31 | 56.0 Kbps
 | %L32 | 58.0 Kbps
 | %L33 | 60.0 Kbps
 | %L34 | 28000 bps
 | %L35 | 29333 bps
 | %L36 | 30666 bps
 | %L37 | 33333 bps
 | %L38 | 34666 bps
 | %L39 | 37333 bps
 | %L40 | 38666 bps
 | %L41 | 41333 bps
 | %L42 | 42666 bps
 | %L43 | 45333 bps
 | %L44 | 46666 bps
 | %L45 | 49333 bps
 | %L46 | 50666 bps
 | %L47 | 53333 bps
 | %L48 | 54666 bps
\K |  | 中断处理方式
 | \K1 | 破坏性加速
 | \K3 | 非破坏性加速
 | \K5 | 非破坏性非加速
\N |  | 纠错 (EC) 模式
 | \N0 | 一般
 | \N1 | 直接
 | \N4 | 仅 LAP-M
 | \N6 | 可靠的
 | \N7 | 自动可靠
\Q |  | DTE 流控制
 | \Q0 | 禁用
 | \Q1 | XON/XOFF（软件流控制）
 | \Q3 | RTS/CTS（硬件流控制）
\T |  | DTE 不活动时断开
 | \T0 | 禁用
 | \Tn | 在处于不活动状态 n 分钟后由计算机中断连接；其中 n = 0 到 255
\V |  | 连接消息格式 决定调制解调器在连接期间生成哪些消息
 | \V0 | 显示 DTE 速率
 | \V1 | 带 EC /DC 消息的 DTE
 | \V2 | 显示 DCE 速率
 | \V3 | 带 EC/DC 消息的 DCE
 | \V4 | 带调制和 EC/DC 消息的 DCE

表 1：AT%（百分比）和 AT\（反斜杠）命令


AT+（加号）命令：Motorola SM56 软件调制解调器用户指南

该调制解调器响应以下 AT+ 命令选项。字母 AT（或 at）必须先于所有命令，A/ 和 +++ 除外。

出厂时默认选项带有下划线。

以下列字符开头的 AT 命令：

+D 控制数据压缩

+F 控制传真应用程序操作

这些命令主要由软件应用程序使用。

命令 | 选项 | 说明
+A8E |  | V.8 配置
 | +A8=a,b,c,d |
 | a 选项： | 指定 V.8 原协商选项
 | 0 | 禁用
 | 1 | 启用计算机控制的 V.8 原协商
 | 6 | 启用计算机控制的 V.8 原协商（带 +A8x 指示）
 | b 选项： | 指定 V.8 应答协商选项
 | 0 | 禁用
 | 1 | 启用计算机控制的 V.8 应答协商
 | 5 | 启用计算机控制的 V.8 应答协商（带 +A8x 指示）
 | c 选项： | 指定 V.8 CI 信号呼叫功能，八位字节选项
 | 00h - FFh, 默认值=00h |
 | d 选项： | 指定 V.8 控制选项
 | 0 | 已禁用
 | 1 | 启用，调制解调器控制
 | 2 | 启用，计算机控制
+A8T |  | V.8bis 信号和消息控制
 | +A8T=a,b,c,d,e,f |
 | a 选项： | 指定要传送的 V.8bis 信号
 | 0 | 无
 | 1 | 启动 MRe
 | 2 | 启动 MRd
 | 3 | 启动 Cre，低功率
 | 4 | 启动 Cre，高功率
 | 5 | 启动 Crd
 | 6 | 启动 Esi
 | 7 | 响应 MRd，低功率
 | 8 | 响应 MRd，高功率
 | 9 | 响应 CRd
 | 10 | 响应 ESr
 | b 选项： | 指定 V.8bis 传送消息 1
 |  | 十六进制八位字节编码串
 | c 选项： | 指定 V.8bis 传送消息 2
 |  | 十六进制八位字节编码串
 | d 选项： | 指定 V.8bis 信号检测
 | 0 | 启用对 V.8bis 信号进行检测
 | 1 | 启用响应 V.8bis 信号检测
 | 2 | 启用两个 V.8bis 信号检测
 | e 选项： | 指定 V.8bis 消息检测
 | 0 | 禁用检测
 | 1 | 启用检测
 | f 选项： | 指定 V.8bis 消息延迟
 | 0 | 传送信号和传送消息之间没有延迟
 | 1 | 在传送信号和传送任何消息之间有 1.5 秒的延迟
+DR |  | 数据压缩 (DC) 报告
 | +DR=0 | 已禁用
 | +DR=1 | 已启用
+DS |  | 数据压缩控制
 | +DS=p,q,r,s |
 | p 选项： | 指定压缩启用/禁用检测
 | 0 | 不压缩
 | 1 | 只有 Tx 方向
 | 2 | 只有 Rx 方向
 | 3 | 双向；接受任何方向
 | q 选项： | 指定协商
 | 0 | 如果数据压缩未按“方向”选项协商，则不能断开连接
 | 1 | 如果数据压缩未按“方向”选项协商，则断开连接
 | r 选项： | 指定最大字典大小
 | 512 - 65535 | 默认值=2048
 | s 选项： | 指定最大串大小
 | 6 - 250 | 默认值 = 32
+EB |  | 中断处理控制
 | +EB=p,q r |
 | p 选项： | 指定中断选择
 | 0 | 忽略中断
 | 1 | 非加速，非破坏
 | 2 | 加速，非破坏
 | 3 | 加速，破坏
 | q 选项： | 指定中断长度控制
 | 0 | V.42 L- 信号的传送不指示中断长度
 | 1 | V.42L- 信号的传送指示中断长度
 | r 选项： | 指定默认中断长度
 | 0 | 不将中断传送到计算机
 | 1- 254，默认值=100 | 中断长度（以 0.01 秒为单位递增）
+ER |  | 错误控制报告
 | +ER=a |
 | a 选项： | 指定调制解调器的错误控制报告活动
 | 0 | 已禁用
 | 1 | 已启用：调制解调器在发布连接消息之前，先向计算机发布以下消息之一。该消息指定协商的“纠错协议”：+ER:NONE+ER:LAPM+ER:ALT
+ES |  | 纠错 (EC) 控制
 | +ES=p,q r |
 | p 选项： | 指定始发调制解调器的请求纠错模式
 | 0 | 直接模式
 | 1 | 一般模式
 | 2 | 仅 LAP-M
 | 3 | LAP-M 或 MNP
 | 4 | 仅 MNP
 | 6 | 建立连接后，启动同步访问模式
 | q 选项： | 指定应答调制解调器的低效率运行纠错模式
 | 0 | EC 可选，返回到一般模式
 | 1 | EC 可选，返回到直接模式
 | 2 | EC 必需（LAP-M 或 MNP）
 | 3 | EC 必需（仅 LAP-M）
 | 4 | EC 必需（仅 MNP）
 | r 选项： | 指定始发调制解调器的低效率运行纠错模式
 | 0 | 直接模式
 | 1 | 一般模式
 | 2 | EC 可选，返回到一般模式
 | 3 | EC 可选，返回到直接模式
 | 4 | EC 必需（LAP-M 或 MNP）
 | 5 | EC 必需（仅 LAP-M）
 | 6 | EC 必需（仅 MNP）
 | 8 | 连接后启动同步访问模式
+ESA |  | 同步访问模式配置
 | +ESA=a,b,c,d,e,f |
 | a 选项： | 指定透明子模式中的空闲状态
 | 0 | 计算机在空闲时传送 8 位同步序列。计算机不搜索同步序列
 | b 选项： | 指定帧子模式中的空闲状态
 | 0 | 计算机在空闲时传送 HDLC 标记符
 | c 选项： | 指定帧子模式中的欠载运行和超限运行
 | 0 | 计算机在一个帧中欠载运行时传送异常中止
 | 1 | 计算机在一个帧中欠载运行时传送标记符，并向调制解调器通知任何欠载运行和超限运行
 | d 选项 | 指定半双工控制。不可用。
 | e 选项 | 指定循环响应代码 (CRC) 的类型
 | 0 | 已禁用。没有 CRC 生成或检查
 | 1 | 在帧子模式中，计算机在“传送”方向中生成 16 位 CRC，调制解调器在“接收”方向上生成 16 位 CRC。
 | f 选项： | 指定非归零（NRZI）选项
 | 0 | 禁用非归零编码和解码。
+ETBM |  | 断开缓冲延迟控制
 | +ETBM=p,q r |
 | p 选项： | 指定未决传送数据的断开缓冲延迟
 | 0 | 放弃缓冲数据并断开
 | 1 | 在所有数据输出之前始终尝试传送，然后断开。忽略计时器。
 | 2 | 在所有数据输出或计时器到期之前始终尝试传送。
 | q 选项： | 指定未决接收数据的断开缓冲延迟
 | 0 | 放弃缓冲数据并断开
 | 1 | 在所有数据输出之前始终尝试传送，然后断开。忽略计时器。
 | 2 | 在所有数据输出或计时器到期之前始终尝试传送。
 | r 选项： 1-255，默认值=0 | 断开缓冲延迟计时器（以 1 秒为单位递增）。
+FCLASS |  | 传真/数据模式
 | +FCLASS=0 | 数据模式
 | +FCLASS=1 | 传真级别 1
 | +FCLASS=8 | 语音模式（在数据/传真/TAM 调制解调器上不适用）。
+FLO |  | 传真流控制
 | +FLO=0 | 无
 | +FLO=1 | XON/XOFF
 | +FLO=2 | RTS/CTS
+FMI? |  | 报告生产商 ID
+FMM? |  | 报告调制解调器 ID
+FMR? |  | 报告修正版级别
+FRH |  | 接收高级数据链接控制 (HDLC) 模式 设置传真的模式和传送/接收速率
 | +FRH=3 | V.21，速率是 300 bps
 | +FRH=24 | V.27ter，速率是 2.4 Kbps
 | +FRH=48 | V.27ter，速率是 4.8 Kbps
 | +FRH=72 | V.27ter，速率是 7.2 Kbps
 | +FRH=73 | V.27ter，速率是 7.2 Kbps（含长排序时间）
 | +FRH=74 | V.27ter，速率是 7.2 Kbps（含短排序时间）
 | +FRH=96 | V.29，速率是 9.6 Kbps
 | +FRH=97 | V.17，速率是 9.6 Kbps（含长排序时间）
 | +FRH=98 | V.17，速率是 9.6 Kbps（含短排序时间）
 | +FRH=121 | V.17，速率是 12.0 Kbps（含长排序时间）
 | +FRH=122 | V.17，速率是 12.0 Kbps（含短排序时间）
 | +FRH=145 | V.17，速率是 14.4 Kbps（含长排序时间）
 | +FRH=146 | V.17，速率是 14.4 Kbps（含短排序时间）
+FRM | +FRM | 接收模式 设置接收传真的调制模式
 | +FRMm | 使用模式 m；请参见上述模式选项 +FRH。
+FRS |  | 等候静止
 | +FRSn | 等候 (n*10) 分钟；n=0 到 255
+FTH | +FTH | 传送高级数据链接控制 (HDLC) 模式
 | +FTH模式 | 使用模式 mode；请参见上述选项 +FRH。
+FTM | +FTM | 传送模式 设置传送传真的调制模式
 | +FTM模式 | 使用模式 mode；请参见上述选项 +FRH。
+FTS |  | 暂停传送
 | +FTSn | 传送暂停 (n*10) 分钟；n=0 到 255
+GCAP |  | 报告性能
 | +GCAP | 显示调制解调器的性能
+GCI |  | 安装的国家/地区
 | +GCI=a | 设置调制解调器安装所在的国家/地区
 | 00 | 日本
 | 04 | 德国
 | 07 | 阿根廷
 | 09 | 澳大利亚
 | 0A | 奥地利
 | 0F | 比利时
 | 16 | 巴西
 | 1B | 保加利亚
 | 20 | 加拿大
 | 25 | 智利
 | 26 | 中国
 | 27 | 哥伦比亚
 | 2E | 捷克共和国
 | 2D | 塞浦路斯
 | 31 | 丹麦
 | 3C | 芬兰
 | 3D | 法国
 | 42 | 德国
 | 50 | 中国香港特别行政区
 | 57 | 爱尔兰
 | 58 | 以色列
 | 59 | 意大利
 | 5E | 约旦
 | 61 | 朝鲜
 | 68 | 列支敦士登
 | 6C | 马来西亚
 | 70 | 马耳他
 | 7B | 荷兰
 | 82 | 挪威
 | 8B | 葡萄牙
 | 8C | 波多黎各
 | 9C | 新加坡
 | 9F | 南非
 | A0 | 西班牙
 | A5 | 瑞典
 | A6 | 瑞士
 | A9 | 泰国
 | AE | 土耳其
 | B4 | 英国
 | B5 | 美国
 | BB | 委内瑞拉
 | BC | 越南
+GMI |  | 请求生产商 ID
 | +GMI? | 显示调制解调器生产商信息
+GMM |  | 请求型号 ID
 | +GMM? | 显示调制解调器型号信息
+GMR |  | 请求软件修正版本号
 | +GMR? | 显示调制解调器软件修正版本号
+IFC |  | 流控制
 | +IFC=p,q |
 | p 选项： | 为通过调制解调器传送（下行）的数据指定计算机的流控制方式
 | 0 | 无
 | 1 | XON/XOFF 流控制，无传递
 | 2 | RTS 流控制
 | 3 | XON/XOFF 流控制，具有传递
 | q 选项： | 为从调制解调器传送（上行）的数据指定调制解调器流控制方式
 | 0 | 无
 | 1 | XON/XOFF 流控制，无传递
 | 2 | CTS 流控制
+ILRR |  | 计算机本地速率报告
 | +ILRR=0 | 已禁用
 | +ILRR=1 | 已启用
+ITF |  | 传送流控制阈值 (V.80)
 | +ITF=a,b |
 | a 选项： | 指定调制解调器禁用传送流控制的阈值（以八位字节为单位）
 | 0-2047 默认值=255 |
 | b 选项： | 指定调制解调器启用传送流控制的阈值（以八位字节为单位）
 | 0-2047 默认值=255 |
+MR |  | 调制模式报告
 | +MR=0 | 已禁用
 | +MR=1 | 已启用
+MS |  | 调制控制
 | +MS=p,q,r,s,t,u |
 | p 选项： | 指定调制模式
 | V21 | V.21
 | V22 | V.22
 | V22B | V.22bis
 | V23C | V.23c
 | V32 | V.32
 | V32B | V.32bis
 | V34 | V.34
 | K56FLEX | K56flex(TM)
 | V90 | V.90
 | V92 | V.92
 | q 选项： | 指定自动模式选项
 | 0 | 已禁用
 | 1 | 已启用
 | r 选项： | 指定 Tx 方向中的最小数据速率
 | 0 | 使用指定调制模式的最小速率 (300 bps)
 | 300 - 33600 | bps
 | s 选项： | 指定 Tx 方向中的最大数据速率
 | 0 | 使用指定调制模式的最大速率
 | 300 - 33600 | bps
 | t 选项： | 指定 Rx 方向中的最小数据速率
 | 0 | 使用指定调制模式的最小速率
 | 300 - 60000 | bps
 | u 选项： | 指定 Rx 方向中的最大数据速率
 | 0 | 使用指定调制模式的最大速率
 | 300 - 60000 | bps
+VCID |  | 主叫用户身份控制
 |  | 只有其功能被支持，这一选项才有效。数据/传真调制解调器不支持该选项。
 | +VCID=0 | 禁用
 | +VCID=1 | 启用
 | +VCID=? | 显示主叫用户身份状态（返回 0 到 1）
+VDR |  | 区别振铃控制和报告
 |  | 只有其功能被支持，这一选项才有效。数据/传真调制解调器不支持该选项。
 | +VDR=m,n | 注意：如果区别铃可使用，那么调制解调器第一个报铃也许不正确。
 | m 选项： | 指定控制
 | 0 | 禁用
 | 1 | 启用
 | n 选项： | 指定报告
 | 0 | 生产 DROFF/DRON 报告，无振铃
 | 1-255 | 生产 DROFF/DRON，延迟 n/10 秒后振铃。
+VEM |  | 事件报告和掩膜控制
仅适用与数据/传真/免提式电话调制解调器
 |  | 位图事件控制掩膜。请参看事件报告字。
+VGR |  | 接收增益
仅适用于数据/传真/免提式电话调制解调器
 | 0 | 自动增益控制
 | 1-255 | 与 128 指示标称值有关的范围。
+VGT |  | 传送量
仅适用于数据/传真/免提式电话调制解调器
 | 1-255 | 与 128 指示标称值有关的范围。
+VIP |  | 初始化话音参数
仅适用于数据/传真/免提式电话调制解调器
 |  | 设置免提式电话参数，请参看厂家默认选项。
+VLS |  | 选择模拟源和目的地
仅适用于数据/传真/免提式电话调制解调器
 | 0 | DCE（调制解调器），挂断
 | 1 | DCE 摘机，DCE 与 telco 相连
 | 8 | DCE 挂断，DCE 与扬声器相连
 | 9 | 可使用静音的免提式电话
 | 11 | DCE 挂断，DCE 与麦克风连接
 | 13 | DCE 摘机，DCE 与 telco、扬声器和麦克风（免提式电话）相连
+VNH |  | 自动挂断控制
仅适用于数据/传真/免提式电话调制解调器
 | +VNH=0 | 保留自动挂断
 | +VNH=1 | DCE 不能提示自动挂断
 | +VNH=2 | 不能使用所有自动挂断
+VPR |  | 语音 DTE-DCE 率
仅适用于数据/传真/免提式电话调制解调器
 | +VPR=0 | 自动波特
+VRA |  | 回铃离开定时器
仅适用于数据/传真/免提式电话调制解调器
 |  | 如果回铃检测完成后，在 n/10 秒里没有再检测到回铃，即可像远程设备应答呼叫一样操作。
 | +VRA=n | 如果没有接收到回铃，在 n/10 秒后，假定远程设备已经应答了呼叫；n = 0-255
 |  | 无回铃
 | +VRN=n | n/10 秒后，按无回铃操作；n = 0-255
+VRX |  | 话音接收模式
仅适用于数据/传真/免提式电话调制解调器
 |  | 决定调制解调器是否生成周期呼叫，让使用免提电话的双方都可听到，提示通话已被录音。
 |  | 注意：在录音或播放信息后，没有必要复位免提电话。在开始播放和开始录音指令前，波特率不被设置。在开始播放和开始录音指令后，波特率不被复位。
 | +VRX or +VRX=0 | 当录音时，生成周期 DCE 音
 | +VRX=1 | 录音时没有周期 DCE 音产生
+VSD |  | 远程静音检测属性
仅适用于数据/传真/免提式电话调制解调器
 | +VSD=m,n | 用于应答设备模式。指定量和通话限度，决定远程设备是否已挂断。
 | m 选项： | 指定静检测级
 | 0 | 使用电流当前 +VSM 值；或，如果当前 +VSM 值是 0，使用 128。
 | 127 | 低限度（最灵敏）
 | 128 | 中限度
 | 129 | 高限度（最不灵敏）
 | n 选项： | 指定静检测通话
 | 0 | 禁用
 | 1-255 | 检测 n/10 秒静寂；n = 0-255
 | 60 | 默认 = 6 秒
+VSM |  | 语言压缩属性
仅适用于数据/传真/免提式电话调制解调器
 | +VSM=m,n,p,q | 指定免提式电话压缩参数
 | m 选择： | 指定压缩方式
 | 128 | PCM
 | 129 | ADPCM
 | n 选项： | 指定抽样率决定是否予以压缩
 | 8000 | 8000 Hz
 | p 选项： | 参数 p 指定压缩和扩展寂静时间。这些参数不能在 1.0 版中执行。您可以空出它们，或填上 0。
 | 0 | 禁用
 | q 选项： | 参数 q 指定压缩和扩展寂静时间。这些参数不能在 1.0 版中执行。您可以空出它们，或填上 0。
 | 0 | 禁用
+VTD |  | 双音频多频率 (DTMF) 音时长
仅适用于数据/传真/免提式电话调制解调器
 | +VTDn | 一般音为 n/100 秒；n = 0-255。默认 = 100。
+VTS |  | DTMF 音一般属性
仅适用于数据/传真/免提式电话调制解调器
 |  | +VTS 可接受被逗号和以下任何类型分离的多项选项。使用所示矩形或旋转支架。
 | D | 生成默认 DTMF 音，默认时长
 | {t,n} | t 指定 DTMF 音；t = 0-9 n 指定音时长 n/100 秒；n = 1-500
 | {f,g,n} | f 和 g 指定音线对，在范围 n 中的 f Hz 和 g Hz 指定音线对时长 n/100 秒；n = 1-500
 | 举例： | AT+VTS=4,{},[1000,1300,50],8,{*,5},[,,100],5 这个例子指定如下顺序： 1. 播放 DTMF 4，时长存储于 +VTD 内 2. 播放寂静，时长存储于 +VTD 内 3. 播放音线对为 1000 Hz 和 1300 Hz 500 ms 4. 播放 DTMF 8，时长存储于 +VTD 内 5. 播放 DTMF*，50 ms 6. 播放寂静，1 秒 7. 播放 DTMF 5，时长存储于 +VTD 内
+VTX |  | 进入话音传送模式
仅适用于数据/传真/免提式电话调制解调器
 |  | 注意：在录音或播放信息后，没有必要复位免提电话。在开始播放和开始录音指令前，波特率不被设置。在开始播放和开始录音指令后，波特率不被复位。


ATH：Motorola SM56 软件调制解调器用户指南

“提示挂机”信号。指示调制解调器进入挂机状态。


ATS（S寄存器）命令：Motorola SM56 软件调制解调器用户指南

调制解调器响应如下 ATS 命令选项。

字母 AT（或 at）必须先于所有命令，A/ 和 +++ 除外。出厂时默认的选项带有下划线。

S 寄存器 | 选项 | 说明
S0 |  | 在振铃一定次数后自动应答
 | S0=0 | 禁用
 | S0=n | 在振铃 n 次后应答；n=0 到 255
S1 |  | 振铃计数
 | S1=n | 计算呼入的振铃次数。如果调制解调器被配置为自动应答（将 S0 设置为非零选项），则当 S1=S0 时，调制解调器会应答呼叫。
S2 |  | 选择转义字符
 | S2=n | 指定转义的 ASCII 字符；n=0 到 255。默认值 = 43 (+)
S3 |  | 选择回车字符
 | S3=n | 指定回车的 ASCII 字符；n=0 到 127。默认值 = 13 (CR)
S4 |  | 选择换行字符
 | S4=n | 指定换行的 ASCII 字符；n=0 到 127。默认值 = 10 (LF)
S5 |  | 选择退格字符
 | S5=n | 指定退格的 ASCII 字符；n=0 到 127。默认值 = 8 (BS)
S6 |  | 盲拨号
 | S6=n | 拨号前，调制解调器会先进入摘机状态，然后等候 n 秒；n=0 到 255。注意：当 ATX2 或 ATX4 选项有效时，忽略 S6 值。默认值 = 2
S7 |  | 呼叫超时
 | S7=n | 连接必须建立的秒数，否则呼叫将中断；n=1 到 255。默认值 = 60
S8 |  | 暂停延迟
 | S8=n | 为拨号串中的拨号修饰符暂停 n 秒；n=0 到 255。默认值 = 2
S10 |  | DCD 信号丢失断开
 | S10=n | 在 DCD 信号已取消声明 n 秒；n=0 到 255（以 0.1 秒为单位递增）后中断。默认值 = 14
S11 |  | 音长
 | S11=n | 指定产生 DTMF 音时，它的持续时间（以 0.001 秒为单位），n=60 到 255。默认值 =72
S12 |  | 转义码保护时间
 | S12=n | 指定调制解调器识别转义码命令和进入命令模式的时间间隔（以 0.02 秒为单位），该时间间隔必须出现在转义码 (+++) 的任一侧。如果 S12=0，则您输入换码序列的速度不是一个因子。默认值 = 50
S18 |  | 测试计时器
 | S18=n | 指定执行测试的持续时间；n=0 到 255。默认值 = 0

表 1：ATS（S 寄存器）命令


AT#UD 单调制解调器诊断命令：Motorola SM56 软件调制解调器用户指南

单调制解调器诊断命令规格由 Microsoft 提供，使调制解调器能够在数据会话诊断期间显示出一致的行为。该命令的最新修订可在 Microsoft Web 站点上找到。

命令语法：

AT#UD

#UD 是一个动作命令。它没有参数。

虽然该命令旨在呼叫终止后使用，却定义了代码，以便调制解调器能够在呼叫放置前进行响应，并且为进行实时监控在呼叫期间进行响应。

命令响应：

为了响应该命令，调制解调器将报告与调制解调器有关的信息。每个信息文本行的格式如下，其中包括一个或多个密钥=值对：

DIAG <令牌密钥 = 值 [[密钥 = 值] [密钥 = 值]]...>

其中，令牌是唯一一个 32 位的十六进制数 2A4D3263

密钥是一个十六进制数，在表 1 的第 1 栏中说明。

值是一个字符串，在表 1 的第 2 栏中定义。

注：除非另有说明，否则所有值都是十六进制数。

密钥 | 值 | 定义
0 | 2 位 | 诊断命令规格修订号
1 | 参见表 2 | 呼叫设置结果代码
2 | 参见表 3 | 多媒体模式
3 | 参见表 4 | DTE-DCE 接口模式
4 | 字符串 | V.8 CM 八位字节字符串，与 V.25ter Annex A 格式相同（用引号括起来）
5 | 字符串 | V.8 JM 八位字节字符串，与 V.25ter Annex A 格式相同（用引号括起来）
6F |  | 为呼叫协商报告保留
10 | 0-2F | 接收信号功率电平，以 -dBm 为单位 (0-43)
11 | 0-1F | 传送信号功率电平，以 -dBm 为单位（例如 0-17）
12 | 0-64 | 估计的噪声电平，以 -dBm 为单位（例如 10-90）
13 | 0-FF | 规格化均方误差，100 (0x64) = 最小的符号间距离
14 | 0-3F | 近回应损耗，单位为 dB
15 | 0-3F | 远回应损耗，单位为 dB
16 | 0-3F | 远回应延迟，单位为分钟
17 | 0-FFF | 环程延迟，单位为分钟
18 | 参见表 5 | V.34 INFO 位图
19-1F |  | 为调制设置和排序报告保留
20 | 参见表 6 | 传送载波协商结果
21 | 参见表 6 | 接收载波协商结果
22 | 0-1F40 | 传送载波符号速率 (0-8000)，单位为符号/秒
23 | 0-1F40 | 接收载波符号速率 (0-8000)，单位为符号/秒
24 | 0-FA0 | 传送载波频率 (0-4000)，单位为赫兹
25 | 0-FA0 | 接收载波频率 (0-4000)，单位为赫兹
26 | 0-FA00 | 初始传送载波数据速率 (0-64000)，单位为比特/秒
27 | 0-FA00 | 初始接收载波数据速率 (0-64000)，单位为比特/秒
28-2F |  | 保留
30 | 0-FF | 临时载波损耗事件计数
31 | 0-FF | 载波速率重新协商事件计数
32 | 0-FF | 已请求载波重新排序
33 | 0-FF | 已准许载波重新排序请求
34 | 0-FA00 | 最终传送载波数据速率，单位为比特/秒
35 | 0-FA00 | 最终接收载波数据速率，单位为比特/秒
36-3F |  | 保留
40 | 参见表 7 | 协议协商结果
41 | 0-400 | 错误控制帧大小，单位为字节
42 | 0-FF | 传输中的错误控制链接超时
43 | 0-FF | 已接收的错误控制链接 NAK
44 | 参见表 8 | 压缩协商结果
45 | 0-800 | 压缩字典大小，单位为字节
46-4F |  | 保留
50 | 0-2 | 传送流控制：0 = 关；1 = DC1/DC3；2 = V.24 ckt 106/133
51 | 0-2 | 接收流控制：0 = 关；1 = DC1/DC3；2 = V.24 ckt 106/133
52 | 0-FFFFFFFF | 传送从 DTE 发送的字符
53 | 0-FFFFFFFF | 接收发送至 DTE 的字符
54 | 0-FFFF | 传送字符丢失（来自 DTE 的数据超限错误）
55 | 0-FFFF | 接收字符丢失（到 DTE 的数据超限错误）
56 | 0-FFFFFFFF | 传送 I 帧计数，如果错误控制协议正在运行
57 | 0-FFFFFFFF | 接收 I 帧计数，如果错误控制协议正在运行
58 | 0-FFFF | 传送 I 帧错误计数，如果错误控制协议正在运行
59 | 0-FFFF | 接收 I 帧错误计数，如果错误控制协议正在运行
5A-5F |  | 保留
60 | 参见表 9 | 终止原因
62-7F |  | 为该规格的将来版本保留
80-FF |  | 为制造商所有权密钥保留

表 1 - AT#UD 上次呼叫状态报告格式

代码 | 说明
0 | 没有以前的呼叫（调制解调器日志中所有以前的呼叫都已被清除）
1 | 没有检测到拨号音
2 | 检测到重新排序信号，网络忙
3 | 检测到忙信号
4 | 没有检测到可以识别的信号（例如：没有信号或没有可识别的信号）
5 | 检测到语音* 如果这是以语音模式（例如 +FCLASS=8.0）运行的语音调制解调器（例如 V.253）
6 | 检测到文本电话信号（参见 V.18）
7 | 检测到数据应答信号（例如：V.25 ANS、V.8 ANSam）
8 | 检测到数据呼叫信号（例如：V.25 CT、V.8 CI）
9 | 检测到传真应答信号（例如：T.30 CED、DIS）
A | 检测到传真呼叫信号（例如：T.30 CNG）
B | 检测到 V.8bis 信号
C-F | 保留

表 2 - 呼叫设置结果代码

代码 | 说明
0 | 仅用于数据
1 | 仅用于传真
2 | 仅用于语音 * 如果支持语音模式（例如：V.253、IS-101）
3 | VoiceView
4 | ASVD，V.61
5 | ASVD, "V.34Q"
6 | DSVD, Multi-Tech
7 | DSVD, 1.2
8 | DSVD, V.70
9 | 视频电话，H.324
A | 其它 V.80 呼叫
B-F | 保留

表 3 - 多媒体模式

代码 | 定义
0 | 异步数据
1 | V.80 透明同步模式
2 | V.80 帧化同步模式
3-F | 保留

表 4 - DTE-DCE 模式

比特 | 源比特 | 定义
31-30 | INFO0 比特 20; 0 |
20-29 | INFOc 比特 79-88 |
16-19 | INFOc 比特 26-29 或 35-38 或 44-47 或 53-56- 或 62-65 或 71-74 | 前置强调字段，由所选的符号速率选择
12-15 | INFOa 比特 26-29 |
10-11 | MP 比特 50; 0 |
0-9 | INFOa 比特 40-49 |

表 5 - V.34 INFO 比特报告（仅适用于 V.34 或 V.90/V.92 呼叫）

值 | 说明
0 | V.17（G3 传真呼叫）
1 | V.21
2 | V.22
3 | V.22bis
4 | V.23 恒定载波 (1200/75)
5 | V.23 切换载波（半双工）
6 | V.26bis
7 | V.26ter
8 | V.27ter（G3 传真呼叫）
9 | V.29 HD（G3 传真呼叫）
A | V.32（很难与 V.32bis 区分）
B | V.32bis
C | V.34
D | V.34 HD（G3 传真呼叫）
E | V.90 第 1 版（不对称）
F | V.90 第 2 版（对称）
E-7F | 保留 (V.58)
80 | X2™
81 | K56FLEX™
82 | V.FC
83 | V.32terbo
84 | Bell 212A（若调制解调器支持 B212A）
85 | Bell 103（若调制解调器支持 B103）
80-FF | 为 mfgs 保留

表 6 - gstnModulationSchemeActive（自 3.7.2/V.58）

值 | 说明
0 | 禁用/无
1 | V.42 LAPM
2 | V.42 备用协议(MNP™)
3-7F | 保留（V.58）
80 | MNP10™
81 | ECP™ 增强蜂窝系统协议
82 | ETC™ 增强吞吐量蜂窝系统
82-FF | 为 mfgs 保留

表 7 - errorControl Active（自 3.5.2/V.58）

值 | 说明
0 | 无
1 | V.42bis
2-7F | 保留 (V.58)
80 | MNP5™
81-FF | 为 mfgs 保留

表 8 - compressionActive（自 3.2.2/V.58）

指出 DCE 已经挂机，先前存在的网络连接已断开。这些值都是十六进制。

值 | 说明 | 注
0 | 原因未明 | 呼叫设置问题
1 | 没有以前的呼叫 | 不在 V.58 中
2 | 呼叫仍在进行中 | 不在 V.58 中
3 | 检测到呼叫等候信号 | 不在 V.58 中，只有调制解调器能够检测到它
4 | 延迟 | 与值 2A 相同，CallAttemptsLimitExceeded
A | NMSinitiatedDialCall | ─ 网络管理系统
B | NMSinitiatedLeasedLineRestoral |
C | NMSinitiatedRedial |
D | NMSinitiatedDialDisconnect |
14 | PowerLoss | DCE
15 | EquipmentFailure |
16 | FrontPanelDisconnectRequested | 如果存在一个带有该控制的前面板
17 | FrontPanelLeasedLineRestoral |
18 | AutomaticLeasedLineRestoral |
19 | InactivityTimerExpired |
1E | cct116RestoralRequest | DTE 接口
1F | cct108isOffInhibitsDial |
20 | cct108turnedOff | 这是使用 &D2 的挂机
28 | NoNumberProvided | 为某些国家/地区的法规所禁止
29 | BlacklistedNumber |
2A | CallAttemptsLimitExceeded | 与“延迟”相同，参见 ETS 300 001
2B | ExtensionPhoneOffHook | 如果支持分机检测
2C | CallSetupFailTimerExpired | 例如：S7 超时
2D | IncomingCallDetected | 如果在发送拨号命令时有呼入。
2E | LoopCurrentInterrupted |
2F | NoDialTone |
30 | VoiceDetected |
31 | ReorderTone |
32 | SitTone |
33 | EngagedTone |
34 | LongSpaceDisconnect | 如果调制解调器程序在长空格上中止
3C | CarrierLost | 信号转换器
3D | TrainingFailed |
3E | NoModulationinCommon |
3F | RetrainFailed |
40 | RetrainAttemptCountExceeded |
41 | GstnCleardownReceived |
42 | FaxDetected |
46 | InTestMode | 测试
47 | IntrusiveSelfTestInitiated |
50 | AnyKeyAbort | 呼叫控制
51 | DteHangupCommand | 如果使用 ATH 终止以前的呼叫。
52 | DteResetCommand | 如果使用 ATZ 终止以前的呼叫。
5A | FrameReject | 错误控制
5B | NoErrorControlEstablished | 需要错误控制
5C | ProtocolViolation |
5D | n400exceeded |
5E | NegotiationFailed |
5F | DisconnectFrameReceived |
60 | SabmeFrameReceived |
64 | LossOfSynchronization | 数据压缩

表 9 - callCleared 代码（自 3.6.4/V.58-1994）

调制解调器响应与用法示例

调制解调器响应 lin | 说明
DIAG <2A4D3263 0=10 | 这是 1.0 版
DIAG <2A4D3263 1=06 2=0 3=0> | 检测到数据应答信号；只有数据；字符异步
DIAG <2A4D3263 5="C14513902A" 6="A145" | V.8 呼叫菜单指示： V.8 连接菜单选择：
DIAG <2A4D3263 10=1F 11=0C 12=52> | 接收电平 = -31dbm，传送电平 = -12dbm；噪声电平 = -82dbm
DIAG <2A4D3263 14=03 15=05 16=10> | 远端回应延迟（以毫秒为单位）；远端回应损耗（以 dB 为单位）；近端回应损耗 = 16 dB
DIAG <2A4D3263 20=C 22=780 24=0C80 26=79E0 > | 传送方：V.34 排序完成；V.34 载波频率 = 1920；V.34 符号速率 = 3200；初始传送速率为 31200 比特/秒
DIAG <2A4D3263 21=D 25=1F40 27=DAC0 > | 接收方：V.90 排序完成；V.90 符号速率 = 8000；初始接收速率为 56000 比特/秒
DIAG <2A4D3263 30=00 31=03 32=01 33=01> | 没有载波丢失事件，尝试了 3 次载波速率重新协商；请求了 1 次载波重新排序；批准了 1 次载波重新排序
DIAG <2A4D3263 34=7080 35=CB20> | 最终传送速率为 28800 比特/秒；最终接收速率为 52000 比特/秒
DIAG <2A4D3263 40=1 41=100> | LAPM 协商完成；帧大小 = 256
DIAG <2A4D3263 42=0 43=0> | 没有错误控制超时或链接 NAK
DIAG <2A4D3263 44=1 45=400> | 使用了 V.42bis 数据压缩；字典大小 = 1024
DIAG <2A4D3263 50=2 51=2> | 硬件传送和接收流控制
DIAG <2A4D3263 52=343CC 54=0> | 传送了 213964 DTE 字符， w/o 欠载运行
DIAG <2A4D3263 53=7230E6 55=47> | 收到了 7483622 DTE 字符，由于接收数据超限，71 个字符丢失
DIAG <2A4D3263 56=29D 58=0001> | 传送了 597（十进制）个帧，1 个帧错误
DIAG <2A4D3263 58=2A4B 59=0004> | 收到了 10827（十进制）个帧，4 个帧错误
DIAG <2A4D3263 60=51> | 本地 PC 已启动挂断

表 10 - 完成数据呼叫，在呼叫期间出现了一些错误和速率重新排序


主叫用户身份（仅适用于美国和加拿大）Motorola SM56 软件调制解调器用户指南

返回到“目录”页

主叫用户身份（仅适用于美国和加拿大）：Motorola SM56 软件调制解调器用户指南

注意：该特性在数据/传真调制解调器上不可用。

调制解调器能够检测到由主叫用户身份服务特性生成的信息，它已被许多电话公司提供。如果您需要更多的信息，请与电话公司联系。

主叫用户身份将电话号码、日期和时间在第一声和第二声振铃之间通过电话线传输。在一些地方，像主叫用户姓名等更多的信息亦可通过增强型主叫用户身份提供。

调制解调器可传输主叫用户身份数据到通信应用程序。您也可配置该应用程序去跟踪或处理数据。

如果您通过电话公司签名到主叫用户身份，而它却不工作，请参考故障查找部分。

请注意：主叫用户可以防止主叫用户身份信息被传输。


CTS：Motorola SM56 软件调制解调器用户指南

清除发送信号。当调制解调器准备接收来自计算机的数据时，它会向本地计算机声明该信号。

它是一种更为有效的数据传送方式。

请阅读限制与免责声明的全部内容。


DC：Motorola SM56 软件调制解调器用户指南

数据压缩


DCD：Motorola SM56 软件调制解调器用户指南

数据载波检测信号。当调制解调器已经通过电话线路接收到可接受的载波信号后，它会向本地计算机声明该信号。如果可接受的载波信号丢失，调制解调器将取消声明该信号。

请阅读限制与免责声明的全部内容。


确定您的调制解调器类型：Motorola SM56 软件调制解调器用户指南

有三种不同的 SM56 调制解调器类型，每一种支持不同的特性设置。您可以打开 Windows 控制面板，然后双击调制解调器图标，来查看调制解调器的类型。在应用程序的主窗口会显示您所安装的调制解调器的产品名称。使用下表，在栏 1 中找到您的产品名称。栏 2 列出了您所安装的调制解调器类型，栏 3 列出了不同的调制解调器特性。

产品名称 | 调制解调器类型 | 特性
摩托罗拉 SM56 PCI 传真调制解调器 摩托罗拉 SM56 AC-L 调制解调器 摩托罗拉 SM56 AC-L(s) 调制解调器 摩托罗拉 SM56 AC-L(v) 调制解调器 | 仅用于数据/传真 | • 所有数据和传真模式 • 无电话应答机 (TAM) • 无主叫用户身份 • 无区别振铃 • 无免提式电话
摩托罗拉 SM56 PCI 话音调制解调器 摩托罗拉 SM56 AC-L(s) 话音调制解调器 摩托罗拉 SM56 AC-L(v) 话音调制解调器 | 数据/传真/TAM | • 所有数据和传真模式 • 电话应答机 (TAM) • 主叫用户身份 • 区别振铃 • 无免提式电话
摩托罗拉 SM56 PCI 免提式电话调制解调器 摩托罗拉 SM56 AC-L(s) 免提式电话调制解调器 摩托罗拉 SM56 AC-L(v) 免提式电话调制解调器 | 数据/传真/TAM | • 所有数据和传真模式 • 电话应答机 (TAM) • 主叫用户身份 • 区别振铃 • 全双工免提式电话


诊断测试：Motorola SM56 软件调制解调器用户指南

如果存在通信问题，请运行快速测试以确定调制解调器是否正在响应来自计算机的命令，步骤如下：

1. 在 Windows 任务栏中，选择开始，然后选择设置， 再选择控制面板。打开调制解调器图标。

2. 选择诊断选项卡。

3. 高亮显示连接调制解调器的端口。

4. 选择其它信息。该测试将向调制解调器发送 AT 命令。此时应显示调制解调器的响应。如果没有显示，则关闭开启的应用程序并重新启动计算机。如果发现相同的通信问题，则接下来继续进行 LAL 测试。

有关详细信息，可运行“本地模拟环回 (LAL)”测试。LAL 测试调制解调器是否与本地连接的计算机进行无差错数据传递。

运行 LAL 测试：

1. 运行提供终端仿真模式的通信应用程序。例如，HyperTerminal 应用程序（可在运行 Windows 的计算机上找到）提供终端仿真模式。

2. 发布 AT&F 命令以将调制解调器设置为出厂时默认选项。此时将显示确定。

3. 发布 ATS46=23 命令。

4. 发布 AT&T1 命令（您键入时字符可能不会出现）。请等候十秒钟。

5. 开始在键盘上键入。您键入的字符应该出现。

6. 输入 +++，出现确定。

7. 输入 ATH（挂断）命令，结束 LAL 测试。

如果您键入的字符没有正确显示，关闭正在运行的应用程序并重新启动计算机。如果发现同样的通信问题，请向您的个人计算机或调制解调器供应商报告该问题。


拨号修饰符：Motorola SM56 软件调制解调器用户指南

调制解调器支持以下拨号修饰符。修饰符用于拨号串中，以使调制解调器处理以下情况，例如呼叫卡的使用、位于 PBX 系统中时访问外线以及使用脉冲拨号。

字符： | 名称： | 导致调制解调器：
@ | 静应答 | 等候一声或几声铃声，然后是 5 秒钟静止；然后继续拨打拨号串
H | 断开 | 断开调制解调器与电话线的连接。
K k , < | 暂停延迟 | 暂停；默认时间为 3 秒
P | 脉冲拨号 | 使用脉冲拨号
R | 反向 | 拨号后立刻进入应答模式；当远程调制解调器为只发时使用
T | 音频拨号 | 使用音频拨号
W w | 拨号等候 | 暂停，直到它检测到拨号音频为止
; | 命令模式 | 在不中断已接通的连接的情况下，拨号后返回命令模式。允许将号码作为音频传送。
!& | 拍击 | 拍击叉簧。启用 PBX 拨号特性。


拨号串：Motorola SM56 软件调制解调器用户指南

它是拨号时所需的一系列字符，用于指定要拨打的号码以及调制解调器所采取的动作。

它由数字和特殊字符组成。


区别振铃（仅适用于美国）Motorola SM56 软件调制解调器用户指南

返回到“目录”页

区别振铃（仅适用于美国）：Motorola SM56 软件调制解调器用户指南

注意：该特性在数据/传真调制解调器上不可用。

调制解调器能够检测到由区别振铃服务特性生成的振铃模式，它已被许多电话公司提供。如果您需要更多的信息，请与电话公司联系。

区别振铃将多个电话号码分配到您的电话线上。当被呼叫时，每个号码生成不同的振铃模式。它允许您用一条电话线接收像话音呼入、数据和传真等各式各样的呼入。

调制解调器可传输区别振铃数据到通信应用程序。这样，调制解调器能够发送呼叫到相应的应用程序。例如：当一个主叫方拨打您的传真号码时，调制解调器会启动您的传真机。

返回到“目录”页

区别振铃（仅适用于美国）


断开原因和代码：Motorola SM56 软件调制解调器用户指南

当调制解调器与电话线断开连接时，它会生成并保存“断开原因”消息。要显示最近一次断开呼叫的“断开原因”消息，在您的通信应用程序中发布 ATI5 命令。此时将出现以下消息之一。

断开原因消息

英语：

无

DTR 下线

ATH 已接收

远程断开

脱机测试

排序故障

EC 本地请求

已连接

拨号中止

检测到占线音

无拨号音

拨号中止 - 呼入

不正确的 DTR 状态

电话号码被列在黑名单上

重新排序阈值

检测到分号

ABT 超时 - 无回铃

ABT 超时 - 回铃已接收

ABT 超时 - 没有进行呼叫

ABT 超时 - 无应答

回铃后占线

EC - 传送限制

EC - 远程请求

EC - 接收到无效的信息包

EC - 建立错误

EC - 接收器超时

EC - 协商失败

EC - 与协议冲突

EC - 参数不当

EC - 数据压缩错误

FSK 可靠性无效

DTE 不活动超时

EC 远程无 PSTN

重排序超时

话音中断 - VLS＝0

话音到传真/数据开关

未知

表 1：断开原因和代码


DOS 框应用程序支持：Motorola SM56 软件调制解调器用户指南

SM56 调制解调器支持在 Windows 98 DOS 框中运行的应用程序。

要启用 DOS 框支持，请打开 Windows 菜单中的调制解调器图标，并选择启用 DOS 框项目。您不必重新启动 Windows。

当设置基于 DOS 的应用程序来与调制解调器通信时，请使用标准 IRQ 和基本 I/O 信息来用于 COM 端口号。以下是标准 IRQ 和基本 I/O：

COM 端口 IRQ 基本 I/O

COM1 4 3F8

COM2 3 2F8

COM3 4 3E8

COM4 3 2E8

调制解调器使用以下两个 IRQ 来支持基于 DOS 的应用程序：

• 标准 DOS IRQ，在前面列出

• IRQ，它在调制解调器“属性”页的“资源”选项卡中列出（“控制面板”，“系统”图标，“设备管理”选项卡）

设置基于 DOS 的应用程序时，确保给它们指派了不同的 IRQ。如果需要，可更改调制解调器的 IRQ，方法是在调制解调器的“资源”选项卡上选择更改设置按钮。


基于DOS 的游戏和应用程序：Motorola SM56 软件调制解调器用户指南

返回到“目录”页

基于 DOS 的游戏和应用程序：Motorola SM56 软件调制解调器用户指南

命令串

您可以将调制解调器与基于 DOS 的游戏和其它应用程序一起使用。大多数都允许将不支持的调制解调器添加到其支持的调制解调器列表中。其它则允许输入关于调制解调器的信息以便使用它。这些应用程序可能需要的信息项目如下：

• 初始化字串 - 将调制解调器设置为已知状态

• 挂断字串 - 终止电话

• 拨号字串 - 指示调制解调器启动电话

• 应答字串 - 指示调制解调器应答电话

• COM 端口速率 - 向调制解调器发出连续的数据

命令串

您可以对调制解调器使用下列命令串。

初始化：AT&F

初始化游戏，这些游戏要求调制解调器不进行纠错和数据压缩：ATS46=23 AT&F\N0

• 挂断：ATH0

• 拨号串：ATDT

• 应答串：ATA

• COM 端口速率：115,200

注意：在命令间不要留有空格。

如果需要有关启用 Windows 98 DOS 支持的详细信息，请参见 DOS 框应用程序支持。


DSR：Motorola SM56 软件调制解调器用户指南

数据设置准备就绪信号。当调制解调器准备进入数据传送阶段时，它向计算机声明该信号。

请阅读限制与免责声明的全部内容。


双音多频：Motorola SM56 软件调制解调器用户指南

电话系统用来与所按的键进行通信的方法。

请阅读限制与免责声明的全部内容。

返回“目录”页


DTR：Motorola SM56 软件调制解调器用户指南

数据终端准备就绪信号。当计算机准备接受数据时向调制解调器发出该信号。

返回“目录”页


事件报告字Motorola SM56 软件调制解调器用户指南

返回到“目录”页

事件报告字：Motorola SM56 软件调制解调器用户指南

您可使用 AT+VEM 指令定义事件报告。该表格被编成由以下的位组成的字。

注意：所有事件被默认为启用，并被带下划线的位编号指示。

A 1 在一个位单元中指示一个事件被报告。

A 0 在一个位单元中指示一个事件未被报告。

读出位从右（位 0）到左（位 32）。

空白表项目是未支持事件使用位。

位 | 信号
0 | 主叫用户身份（只有其功能被电话公司支持，这一选项才有效。数据/传真调制解调器不支持这一选项。）
1 |
2 | 区别振铃（只有其功能被支持，这一选项才有效。）
3 | 振铃
4 | DTMF 检测
5 | 接收缓冲超限
6 | 传真呼叫
7 | 数据呼叫
8 |
9 | 假定挂机（寂静）暂停
10 | 假定报终（静）暂停
11 |
12 |
13 |
14 |
15 |
16 |
17 |
18 | 回铃
19 | 占线
20 | 拨号音
21 |
22 |
23 | 重放缓冲超限
24 |
25 | 传真或数据应答调制解调器检测
26 |
27 | 话音检测
28 |
29 |
30 |
31 |
32 |


EC：Motorola SM56 软件调制解调器用户指南

纠错


一级传真服务：Motorola SM56 软件调制解调器用户指南

如 EIA/TIA-578-A 规格中定义的那样，调制解调器支持第三组一级传真服务。通过传真软件，您可以使用计算机和调制解调器来发送和接收传真传送。如果您在发送传真时遇到问题，请参见 AT+ 命令部分，该命令控制传真操作。


目录：Motorola SM56 软件调制解调器用户指南

Motororla SM56 软件调制解调器用户指南

简介
确定您的调制解调器类型
V.90/V. 92 和 K56flex
技术支持
电话连接器
安装或重新安装调制解调器
卸载和升级 SM56 调制解调器
应用程序的兼容性
DOS 框应用程序支持
基于 DOS 的游戏和应用程序
一级传真服务
主叫用户身份
区别振铃
拨号修饰符
结果代码和连接消息
AT 命令 - 基本原理
+++（加号-加号-加号）命令
AT 和 AT&（“和”符号）命令
AT%（百分比）和 AT（反斜杠）命令
AT*（星号）命令
AT+（加号）命令
ATS（S 寄存器）命令
AT#UD 单调制解调器诊断命令
事件报告字
故障排除
断开原因和代码
诊断测试
卸载调制解调器
如何添加 AT 命令

本文件中的信息可随时更改，恕不另行通知。
(C) 2002 Motorola。保留所有权利。

在本文件中可能使用商标和商品名称来表示对这些标记和名称拥有所有权的实体或其产品。Motorola 不承诺不属于它的任何商标和商品名称的所有权利益。


安装或重新安装调制解调器：Motorola SM56 软件调制解调器用户指南

要求 • 安装调制解调器：硬件 • 安装调制解调器：软件 • Windows 98、Windows Millenium、Windows 2000 和 Windows XP 安装 • Windows NT 4.0 • 在安装中止/取消后恢复

通常，SM56 调制解调器已预装在您的计算机上，但是您可以重新安装它。

警告：一台计算机上只可使用一个卡。

要求

该调制解调器在装有以下系统的个人计算机上运行

• Windows 98、Windows Millenium、Windows NT 4.0、Windows 2000 和 Windows XP 操作系统

• 任何下列处理器/高速缓存配置：

- 150 MHz Pentium(R) 或更快的 CPU（200 MHz，推荐用于 V.90 操作）

- 233 MHz AMD K6(R) 或更快的 CPU（带有 256K L2 高速缓存）

- 266 MHz Cyrix(R) MII 或更快的 CPU（带有 256K L2 高速缓存）

- 266 MHz Intel(R) Celeron 或更快的 CPU

• 8 MB 硬盘空间

• 16 MB RAM - 用于 Windows 98 或 Windows Millenium

• 32 MB RAM - 用于 Windows 2000、Windows NT 4.0、Windows XP

SM56 调制解调器需要：

• 一个空的 32 位 PCI 或一个 AC-L 插槽（用于 SM56 AC-L）

• 一个可用的 IRQ：3 到 15 用于 PCI 调制解调器

• 用于数据/传真/免提式电话和数据/传真/TAM 调制解调器的一个兼容的声卡

安装调制解调器

第 1 部分：硬件安装

按以下步骤安装调制解调器：

1. 打印该“帮助”主题，以便能参照硬拷贝上的内容。

2. 关闭计算机。拔下电源线。

3. 打开计算机并将调制解调器卡插入 PCI 或 AC-L 插槽。

4. 使用电话线将调制解调器连接到模拟电话线插口。

5. 打开计算机。

第 2 部分：软件安装

注意：Windows 即插即用功能会为调制解调器指派一个 COM 端口号。为支持早期的软件应用程序和 Windows 9x DOS 游戏，SM56 安装软件会尝试协商一个在范围 1-4 之内的 COM 端口号。

Windows 98、Windows Millenium、Windows 2000 和 Windows XP 安装

注意：由于操作系统和 Service pack 的版本不同，“安装向导”也可能会稍有不同。

安装了 SM56 调制解调器卡后，初次启动 Windows 时，Windows “配置管理器”会检测新硬件，给它指派资源，然后显示一个窗口要求提供调制解调器软件驱动程序。这表明“配置管理器”正在查找信息 (INF) 文件，该文件中包含该调制解调器的以下信息：

• 设备类型（调制解调器）

• 设备驱动程序信息（控制调制解调器的驱动程序名称）

• AT 命令/响应集

请按照下列步骤安装软件：

• 响应要求窗口。选择由硬件生产商提供的从磁盘安装的驱动程序（或从磁盘安装，根据操作系统的版本而定），找到 SM56 驱动程序所在的位置。Windows 应该查找磁盘上的信息并将该设备标识为 SM56 调制解调器。然后将这些文件从安装磁盘复制到计算机并完成安装。

• 在数据/传真/TAM 和数据/传真/免提式电话调制解调器中，当调制解调器安装完成后会发现其他的设备。Windows 将通知您发现一个用于调制解调器的串行波形设备，并提示需要一个波形设备驱动程序。重新指向 SM56 驱动程序的位置并单击确定。

安装好这两个设备后，SM56 调制解调器安装程序就会启动。

调制解调器安装程序在安装过程中并不提示用户输入。它能自动检测安装的操作系统的国家/地区和语言选项并将安装默认为这些选项。如果是从以前的驱动程序版本升级，会保留这些设置。

Windows NT 4.0 安装

重点： | 用于 Windows NT 的 SM56 软件仅有数据/传真，不支持免提式电话或 TAM。
重点： | 请确保您有用于 NT 4.0 调制解调器的驱动程序。该程序不同于用于 Windows 9x、XP 或 Windows 2000 的驱动程序。

Windows NT 4.0 不完全支持即插即用 (PnP)。因此，在计算机中安装好调制解调器插件板并重新启动后，操作系统将不会自动认出现有的新硬件。您必须从分布媒体中运行 sm56set.exe 来手动安装调制解调器。此安装程序将自动添加一个新的 COM 端口，安装调制解调器，然后将它指定给那个新的 COM 端口。安装完成时，系统将提示您重新启动计算机。使用调制解调器前，您必须这样做。

重点：

目前没有适用于 Windows NT 4.0 的升级应用程序。如果需要将调制解调器升级为一个新版本，您必须卸载先前的版本（从控制面板的添加/删除程序中运行卸载程序），然后按以前自然段所述进行新的安装。

在安装中止/取消后恢复

在调制解调器软件安装过程中，Windows 提供一个消息框，该框具有用户可选的“取消”（或“中止”）按钮。如果在运行调制解调器软件安装时单击了该按钮，将导致调制解调器安装程序仅完成部分安装。只进行一部分调制解调器安装不能确保可正确执行功能。

要完全“清洁”系统，您应该：

1. 转到 Windows“ 控制面板”

2. 选择“添加/删除程序”

3. 选择“SM56 调制解调器”

4. 单击“删除”

5. 重新启动计算机

在重新启动 Windows 时，“即插即用”功能将重新检测调制解调器。将安装向导指向调制解调器驱动程序文件夹并允许整个安装程序完成。现在您的调制解调器就能够使用了。


结果代码和连接消息：Motorola SM56 软件调制解调器用户指南

调制解调器向计算机发送消息以指出连接状态。通信应用程序使用该信息来跟踪连接的进展情况，并执行相应的操作。

消息内容和格式由以下几点决定：

• 结果代码显示 (ATQ ) 参数选项，使结果代码能够显示

• 结果代码格式 (ATV ) 参数选项，决定结果消息格式（长格式文本消息或短格式数字代码）

• 呼叫进展报告 (ATX ) 参数选项，决定所显示消息的类型

• 连接消息 (AT\V ) 参数选项，决定在连接消息内显示的信息类型

必须启用调制解调器的“结果代码显示”参数 (ATQ=1)，才能生成所有消息。

根据“呼叫进展报告 (ATX)”选项，发送以下数字代码或文本消息。当“连接消息”参数 (AT\V) 被设置为“Rate-Only”（仅速率）选项（AT\V0 或 AT\V2）时，可以生成以下所示的连接消息。

代码 | 文本消息 | 呼叫进展报告 (ATX) 选项
0 | 确定 | 0、1、2、3 或 4
1 | 连接 75 | 0
注：如果呼叫进展=0，则收到数字代码 1 仅表示已经进行了连接。如果呼叫进展=1、2、3 或 4，则收到数字代码 1 表示已经以 75 bps 的速率进行了连接。
2 | 振铃 | 0、1、2、3 或 4
3 | 无载波 | 0、1、2、3 或 4
4 | 错误 | 0、1、2、3 或 4
5 | 连接 1200 | 1、2、3 或 4
6 | 无拨号音 | 2 或 4
7 | 占线 | 3 或 4
8 | 无应答 | 0、1、2、3 或 4
10 | 连接 2400 | 1、2、3 或 4
11 | 连接 4800 | 1、2、3 或
12 | 连接 9600 | 1、2、3 或 4
13 | 连接 600 | 1、2、3 或 4
20 | 连接 300 | 1、2、3 或 4
22 | 连接 7200 | 1、2、3 或 4
23 | 连接 12000 | 1、2、3 或 4
24 | 连接 14400 | 1、2、3 或 4
25 | 连接 16800 | 1、2、3 或 4
26 | 连接 19200 | 1、2、3 或 4
27 | 连接 21600 | 1、2、3 或 4
28 | 连接 24000 | 1、2、3 或 4
29 | 连接 26400 | 1、2、3 或 4
30 | 连接 28800 | 1、2、3 或 4
31 | 连接 31200 | 1、2、3 或 4
32 | 连接 33600 | 1、2、3 或 4
34 | 连接 38400 | 1、2、3 或 4
35 | 连接 57600 | 1、2、3 或 4
36 | 连接 115200 | 1、2、3 或 4
37 | 连接 32000 | 1、2、3 或 4
38 | 连接 34000 | 1、2、3 或 4
39 | 连接 36000 | 1、2、3 或 4
40 | 连接 38000 | 1、2、3 或 4
41 | 连接 40000 | 1、2、3 或 4
42 | 连接 42000 | 1、2、3 或 4
44 | 连接 44000 | 1、2、3 或 4
46 | 连接 46000 | 1、2、3 或 4
48 | 连接 48000 | 1、2、3 或 4
50 | 连接 50000 | 1、2、3 或 4
52 | 连接 52000 | 1、2、3 或 4
54 | 连接 54000 | 1、2、3 或 4
56 | 连接 56000 | 1、2、3 或 4
58 | 连接 58000 | 1、2、3 或 4
60 | 连接 60000 | 1、2、3 或 4
61 | 连接 28000 | 1、2、3 或 4
62 | 连接 29333 | 1、2、3 或 4
63 | 连接 30666 | 1、2、3 或 4
64 | 连接 33333 | 1、2、3 或 4
65 | 连接 34666 | 1、2、3 或 4
66 | 连接 37333 | 1、2、3 或 4
67 | 连接 38666 | 1、2、3 或 4
68 | 连接 41333 | 1、2、3 或 4
69 | 连接 42666 | 1、2、3 或 4
70 | 连接 45333 | 1、2、3 或 4
71 | 连接 46666 | 1、2、3 或 4
72 | 连接 49333 | 1、2、3 或 4
73 | 连接 50666 | 1、2、3 或 4
74 | 连接 53333 | 1、2、3 或 4
75 | 连接 54666 | 1、2、3 或 4

注：速率单位为比特/秒

表 1：结果代码

也可以配置“连接信息”来指明以下信息：

• 调制解调器的调制模式

• 用于连接的纠错类型和数据压缩方式

当“呼叫进展报告”参数 (ATX) 被设置为非零选项时，基于“连接消息 (AT\V)”选项，可发送的连接消息的类型如下。没有这些消息的数字代码。

连接消息 (AT\V) 选项 | 文本消息
1 | 连接 rxrate
 | 连接 rxrate/ec
 | 连接 rxrate/ec/dc
3 | 连接 rxrate
 | 连接 rxrate/ec
 | 连接 rxrate/ec/dc
4 | 连接 rxrate/mode
 | 连接 rxrate/mode/ec
 | 连接 rxrate/mode/ec/dc
 | 连接 rxrate/txrate/mode
 | 连接 rxrate/txrate/mode/ec
 | 连接 rxrate/txrate/mode/ec/dc
其中 rxrate = 接收数据速率（单位为比特/秒） 其中 txrate = 传送数据速率（单位为比特/秒） 其中 dc = V42BIS、MNP5、V44 之一 其中 mode = V34、V32BIS、V32、V23、V22BIS、V21、K56flex!"，V.90、V.92、B212、B103 之一 当 AT\V 被设置为 0 或 1 时，连接消息显示计算机与调制解调器通信的速率 - DTE 速率。 当 AT\V = 2、3 或 4 时，连接消息显示调制解调器与远程调制解调器通信的速率 - DCE 速率。如果接收速率与发送速率不同，则出现异步连接。在此情况下，显示接收速率（如果 AT\V = 4，则其后跟有传送速率）。

表 2：连接消息

示例：其它连接消息

启用了相应的选项后，调制解调器能够生成以下消息。

启用的选项 | 调制解调器生成的消息 | 示例
+ILRR | +ILRR: <速率>[,<rx_rate>] | +ILRR: 19200
+MR | +MCR: <载波> +MRR: <速率>[,<rx_rate>] 注意：<载波> 值与 AT+MS 命令的第一个参数相同。 | +MCR: V32B +MRR: 33600
AT+ER | +ER：无 +ER:LAPM +ER:ALT |
T+DR | +DR：无 +DR:V42B +DR:V42B RD +DR:V42B TD |

表 3：其它连接消息

其它消息

调制解调器可生成以下消息。

数字代码 | 文本消息 | 含义
+F4 | +FCERROR | 检测到无效的传真音或数据载波；调制解调器返回到命令状态。
ERRM=ICLID_202 | ERRM=ICLID_202 | 由电话公司提供的主叫用户身份信息被破坏，因此不能提供该信息。

表 4：其它生成的消息


技术支持：Motorola SM56 软件调制解调器用户指南

如需要电话技术支持，请与您的个人计算机或调制解调器直接供应商联系。

如果您还未查询故障排除部分，请先查询。


电话连接器：Motorola SM56 软件调制解调器用户指南

大多数调制解调器都有两个 RJ-11 电话连接器，上面分别标有 LINE（绿色）和 PHONE 字样。

要设置调制解调器，将电话线从电话服务插口连接到 LINE 连接器。将电话机连接到 PHONE 连接器（可选）。即便关闭了计算机，已连好的电话也可以正常工作。

如果连接了调制解调器，则不能使用该电话。联机时若试图使用该电话可能导致调制解调器中断连接。


故障排除：Motorola SM56 软件调制解调器用户指南

如果在发出呼叫或接收呼叫或传送数据时出现问题，而您的通信应用程序又没有对该问题作出解释，那么请对照以下症状和技巧列表。

Windows 98 DOS 框应用程序不能和该调制解调器一起工作

如果 DOS 框应用程序不工作，请尝试以下工作：

1. 打开控制面板。

2. 双击系统图标。

3. 打开调制解调器选项卡。

4. 双击 Motorola SM56 调制解调器。

5. 选择调制解调器选项卡。记下 COM 端口号。

6. 选择资源选项卡，记下列出的 IRQ 号。

7. 要使 DOS 支持正常运作，SM56 调制解调器不能占用供 COM 端口号使用的标准 IRQ 。

8. 取消对使用自动资源复选框的选择。

9. 双击中断请求标签并将 IRQ 更改为不会与另一个设备冲突的其它号码。（如果没有空闲的 IRQ：释放一个，或更改其它设备的 IRQ 级别以释放非标准 IRQ）。

没有拨号音

1. 确保电话线的两端都已牢固连接。

2. 从计算机上拨下电话线，然后将它直接从墙上插口连接到电话机。检查拨号音，如果没有，问题可能在于电话线路或系统。请与服务提供商联系。

调制解调器不能完成到另一个调制解调器的连接

1. 确保您的调制解调器拨打的是正确号码。确保您已经指定了正确的区号（如果需要区号）。

2. 确定远程调制解调器是否已正确配置，能够与您的调制解调器通信。

调制解调器不应答呼入

1. 确保已将自动应答参数设置为有效选项之一，设置时使用 ATS0 命令（ATS0=1，振铃一次后应答；ATS0=2，振铃两次后应答，依此类推）。

2. 确保在调制解调器应答呼叫之前，其它设备（如传真机或电话应答机）没有应答。

调制解调器在传送进行时断开

1. 确保电话线的两端都已牢固连接。

2. 确保呼叫等候已禁用。在大多数地区，命令 *70 或 #70 会禁用呼叫等候。请与您的电话公司核对正确的密钥序列。（如果有呼叫等候，来电提醒声可能会中断您的电话。）

在非常长的时期内没有传送或接收数据

1. 重新拨打该电话。（电话线路连接可能较差。）

2. 尝试另一个 ISP 号码，服务器可能正忙。

3. 与您的 ISP 联系，查明他们的服务器是否出现问题或向他们咨询为何数据传送缓慢。

计算机运行速度比平常慢

1. 关闭您不使用的所有打开的应用程序。

呼叫音调驱动应用程序时，不能成功输入音调选项。

1. 如果拨打需要使用电话按键输入选项的远程系统（如语音信箱或银行帐号信息提供方），可以延长调制解调器发出的音调的持续时间，以便远程系统能更好地检测它。要调整 DTMF 的音长，使用 AT+VTDn 命令，其中 n 指定音调持续的时间。

调制解调器不响应 AT 命令

1. 确保已将您的通信软件配置为与调制解调器使用相同的 COM 端口。

2. 将调制解调器参数重设置为默认的选项，方法是输入 AT&F，然后重新输入自定义选项。

调制解调器响应命令，却不出现在屏幕上

1. 确保本地显示回应选项已经启用，方法是输入 ATE1。

2. 按 Enter 键。

您已安装新的外围设备；现在调制解调器不能用。

1. 在 Windows 桌面的任务栏上选择开始。

2. 选择帮助。此时出现 Windows 帮助主题窗口。

3. 选择目录选项卡。

4. 选择如果存在硬件冲突。

5. 此时出现一系列故障排除措施。请遵循相应的步骤。

您从计算机音效系统中听到回应（杂音）（数据/传真/免提式电话调制解调器卡）

1. 将喇叭放置在远离麦克风至少三英尺（一公尺）外之处。

2. 确保喇叭不面向麦克风。

3. 降低喇叭音量。

4. 当您对着麦克风说话时，至少将麦克风置于十二英寸（三十公分）之处。将背景声音降至最小。

5. 如果回声仍然存在，在音量控制面板中，将麦克风波峰关闭。

调制解调器连接，然后出现无意义字符

1. 打开控制面板。双击调制解调器图标。

2. 选择 Motorola SM56 调制解调器。

3. 单击属性。

4. 选择连接。

5. 单击高级。

6. 复选对连接使用所需的差错控制复选框。

调制解调器不能连接；选择了“差错控制”选项

调制解调器的连接速率可能高于适合该线路条件的速率

1. 使用 AT%B 命令限制 SM56 的最大连接速率。（有关详细信息，参见 AT% 命令部分。）

2. 使用 AT 命令降低速率，直到问题得以纠正为止。您可以添加 AT 命令来执行此操作；参见下一部分。

检测不到调制解调器

1. 重新启动计算机。

2. 若重新启动计算机后仍检测不到调制解调器，则卸载调制解调器，再重新安装一次。


卸载调制解调器：Motorola SM56 软件调制解调器用户指南

卸载调制解调器软件 • 卸除调制解调器硬件

本部分说明如何将调制解调器从一台个人电脑上删除。卸载调制解调器有两个步骤：

• 卸载调制解调器软件

• 卸除调制解调器硬件

卸载调制解调器软件

1. 选择开始，然后依次选择设置和控制面板。

2. 打开添加/删除程序

3. 选择 Motorola SM56 调制解调器卸载。选择添加/删除

卸除调制解调器硬件

1. 关闭计算机。拔下它的电源插头。

警告：从个人计算机取下内部调制解调器前，从个人计算机拔掉电话线并断开所有电源连接。处理调制解调器卡之前，先让它冷却三至四分钟。

2. 拔掉调制解调器卡连接器上的电话线。

3. 打开计算机机盖。

4. 取出调制解调器线路接口卡。

5. 重新盖好计算机机盖。将计算机连接到电源。重新启动计算机。

卸载过程完成。


卸载和升级 SM56 调制解调器：Motorola SM56 软件调制解调器用户指南

SM56 卸载步骤 • SM56 软件升级步骤 (Windows 98) • 从未成功的升级恢复 (Windows 98)

软件升级版推出后，您可以更新版本以享有新增功能。在大多数情况下，不需要新添硬件。

SM56 卸载步骤

1. 打开“控制面板”。

2. 选择添加\删除程序。

3. 在对话框中，选择 Motorola SM56..... 调制解调器卸载。

4. 选择添加/删除。

5. 关闭计算机。

6. 移除计算机上的 SM56 硬件。

SM56 软件升级步骤

您可按下列步骤将 SM56 调制解调器升级到更新的版本。

1. 从您的直接调制解调器供应商取得最新软件版本。

2. 运行 sm56set.exe 并遵照升级指南提示执行。升级实用程序在名为 \Windows\Motorola\Motbak95 的文件夹中保留以前调制解调器版本的备份。它还保留调制解调器 COM 端口设置、国家/地区设置和语言设置，这样所有通信应用程序都将正常执行功能。

注：因为操作系统不断发展变化，因此尚未提供 Windows 2000 的升级应用程序。要升级到新的 Windows 2000 版本，请进行彻底地卸载，然后安装更新的版本。一旦发布操作系统新版本，自动升级应用程序将最终定下来（或稍有延后）。

从未成功的升级恢复

如果在升级 SM56 后，您的新驱动程序有问题，您可以按照以下步骤恢复以前的 SM56 软件安装。请执行以下全部步骤。

1. 打开“控制面板”。选择添加/删除程序。

2. 如果已安装程序列表中列有 SM56 调制解调器，请单击 SM56 调制解调器，然后单击添加/删除以运行卸载程序。

3. 重新启动计算机。

4. 重新启动后，系统会从 \Windows\Motorola\Motbak 备份目录重新安装 SM56 调制解调器。

这将会重新安装先前的调制解调器软件。


V.90/V.92 和 K56flex: Motorola SM56 软件调制解调器用户指南

返回到“目录”页

V.90/V.92 和 K56flex：Motorola SM56 软件调制解调器用户指南

通过 V.90/V.92 和 K56flex(TM) 技术，用户能够以最高两倍于 V.34 调制解调器的速度与 Internet 相连接。最大接收速率为 56Kbps，而返回路径以 V.34 速率（最高 48.0 Kbps）连接。这对于 Internet 连接而言显得尤为完美，因为其中的大多数数据传送是从 Internet 传送到客户端计算机。

使用 V.92 技术，将保证用户与 Internet 服务供应商（ISP）达到极高水平的互操作性。因为为遵循 ITU V.92 倡议，大部分的 ISP 正在向 V.92 转换。

V.92 是当今可用的最新、最先进的模拟调制解调器技术。它为用户提供“宽带般的” Internet 使用经验。V.92 让您可以：

• 最快地与您的 ISP 连接

• 以更快的速率（最高 48Kbps）传送数据

• 当您播放或接收一个一般电话呼叫时，可保持您的 Internet 处于连接状态。（这要求您的 ISP 支持和您电话公司的呼叫等候音服务。）

请访问 V.90 和 V.92 Web 站点 (www.v90.com、www.v92.com) 以获取更为详尽的信息，包括：

• 支持 V.90/V.92 的完整 ISP 名单

• V.90/V.92 的最新信息

• 关于 V.90/V.92 的技术“白皮书”

• 关于 V.90/V.92 的常见问题解答（FAQ）

要使用 V.90/V.92，请与您的 ISP 联系：

• 保证该 ISP 支持 V.90/V.92

• 得到连接 V.9/V.92 的拨入号码

注：由于线路条件的制约，不一定总能达到 56K 的速度。

当调制解调器连接至非 V.90/V.92 前端时：

• 如果前端是符合 K56flex(TM) 的，此 SM56 V.90 调制解调器以 K56flex(TM) 速度连接。

• 如果此前端是符合 X2(TM) 的，此 SM56 V.90 调制解调器以 V.34 速度连接。